Channel 11 issues
Incident Report for LevelEleven
Resolved
The issues that some customers were experiencing with Channel 11 has been resolved. Regular functionality has been restored.
Posted Nov 06, 2019 - 09:16 EST
Investigating
We have identified that there have been some issues with Channel 11. We are investigating the issue, but some customers may experience some interruptions in service. We will keep you updated as we learn more.
Posted Nov 05, 2019 - 14:25 EST
This incident affected: Channel11 Service.