Channel 11 Database Maintenance
Incident Report for LevelEleven
Resolved
Channell 11 database maintenance is complete.
Posted about 2 months ago. May 22, 2018 - 21:16 EDT
Identified
A Channel 11 database is currently undergoing maintenance. Some customers may be affected by this. We expect all customers to be restored by 8pm EST.
Posted about 2 months ago. May 22, 2018 - 17:56 EDT
This incident affected: Channel11 Service.