Some services may be affected by the AWS Outage

Incident Report for LevelEleven

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 20:08 EDT

Monitoring

We have not noticed any issues, but we are actively monitoring the outage
Posted Oct 20, 2025 - 09:29 EDT
This incident affected: Channel11 Service, LevelEleven Website, Contest Engine, and Scorecard.