Channel 11 issues
Incident Report for LevelEleven
Resolved
This incident has been resolved. Please reach out to your CSM or gethelp@leveleleven.com if you are still experiencing issues.
Posted Jul 08, 2020 - 13:18 EDT
Investigating
We are currently investigating an issue concerning the ability to log into Channel 11. We will continue to update here as we make progress and resolve the issue.
Posted Jul 08, 2020 - 11:53 EDT
This incident affected: Channel11 Service.